phpMyAdmin not working from cpanel with Invalid grant string: GRANT USAGE ON Error in logs

MariaDB Upgrade from 10.3.22 to 10.3.23 is causing the below issues and to fix we need to either upgrade the Cpanel to 11.88 tier or downgrade the MySQL version from 10.3.23 to 10.3.22

Errors or Symptoms so far seem to be the below ones

This mainly seems to have effects for cPanel -> MySQL Databases interface and PHPMyAdmin interface which is taken from Cpanel login.

Error 1: The MySQL server is currently offline.
Error 2 : warn [cpmysql] Error (Invalid grant string: GRANT ALL PRIVILEGES ON `dbusername`.* TO `cpanelusername`@`localhost`
) while parsing grant: GRANT ALL PRIVILEGES ON `dbusername`.* TO `cpanelusername`@`localhost` at /usr/local/cpanel/Cpanel/Mysql.pm line 905
Error 3 : *.* TO `cpses_demj`@`ser.ver.ip.1` IDENTIFIED BY PASSWORD
Error 4 : warn [cpanel] Cpanel::Wrap::send_cpwrapd_request adminbin Cpanel/cpmysql/DBCACHE: exit 11: namespace=[Cpanel] module=[cpmysql] function=[DBCACHE]: set error in context mysql: raw_response=[{"version":"2.4","action":"run","data":"Error encountered while fetching data: There is no such grant defined for user 'cpses_username' on host 'localhost'\nDBDISKUSED\tcptech_dbv\t0\nDISKUSED\t0\nDB\tcptech_dbv\nUSER\tcptech_db\n","timeout":0,"mode":"simple","status":1,"exit_code":2816,"error":1,"statusmsg":"adminbin Cpanel/cpmysql/DBCACHE: exit 11"}] at /usr/local/cpanel/Cpanel/Wrap.pm line 120, <$socket> line 1.

 

Special notes :

You are having with 2 options to fix this issue at the moment

  1. As per cPanel, they ask us to upgrade to the next Major version release which is 11.88  to fix this issue. This can cause some issues if you are hosting too many shared accounts or for production servers as it may have bugs and not as stable as 86 version. Some in that link has updated that update to 88 version has caused another issue with softaculous. They do intend to release fixes for the 86 version as well soon.
  2. If you wish to stay with the current Stable version of cPanel which is 11.86, then you need to downgrade MariaDB Version by simply running the below command.
    # yum downgrade MariaDB-server MariaDB-common MariaDB-shared MariaDB-client MariaDB-compat MariaDB-devel

    While doing this make sure the MariaDB is downgrading to 10.3.22 version itself and I strongly suggest to take Mysql dumps before making any changes.

    To take Mysql Dump, Please use this Doc for the exact commands.

Always refer to the cPanel Links which I have pasted in the above for the current status of fixes before applying the above fixes.

 

 

 

 

Scroll to Top